*

Author Topic: Themes/default/languages/Modifications.english.php test failed  (Read 4163 times)

Offline Resourcez

  • Administrator
  • Hero Member
  • *
  • Posts: 1425
    • Resourcez
Themes/default/languages/Modifications.english.php test failed
« on: February 25, 2008, 11:31:15 AM »
Error:
Execute Modification ./Themes/default/languages/Modifications.english.php test failed

Cause:
Invariably this is due to a previous mod installation that has been flawed, typically the Arcade mod.
The very last line of the Modifications.english.php file MUST always be ?>

Arcade had a habit of appending those two characters to the last line of its own code, which screws all subsequent mods (that use that file) by stopping them from finding that reference point and  installing correctly.  It is a flaw in Arcade and I'm getting damned sick of dealing with the problem it creates. There may be other mods that do the same.

Cure:
Edit your Modifications.english.php file and ensure you have a blank line followed by a line with ?> all by itself, as the last line - this is how the file must be, and is how the original SMF file is.

Uninstall Treasury and re-install it - the mod will not have an error notice this time because it will be able to find the ?> that should have been there.

Notes:
If unsure, use the Package Parser to see what Treasury does (correctly) and what other mods may be doing (incorrectly).
Of course, you know you will have to first uninstall any mods you may have added after Treasury.
« Last Edit: February 25, 2008, 02:13:11 PM by Resourcez »
If you have everything under control, you're not moving fast enough.
• Apache 2.2.24 • PHP 5.3.24 • MySQL 5.1.68 •

 

Please Support Us!

Something for Here
Donate with PayPal!
June Goal: $40.00
Due Date: Jun 30
Total Receipts: $0.00
Below Goal: $40.00
Site Currency: USD
 0%

Content